Tag Archives: Icom IC-703 Plus

POTA Field Report: Activating the BRP with my new-to-me Icom IC-703 Plus

When my buddy Don told me he was selling his Icom IC-703 Plus a few weeks ago, he caught me in a (multi-year long)  moment of weakness. I asked his price and followed up with a PayPal transaction without giving it a lot of thought. It was a bit of an impulse purchase, if I’m being completely honest, but he definitely gave me a “friends and family” discount.  (FYI: Don is the same enabler that made this purchase happen.)

I’m thinking the IC-703 Plus might be a good first HF rig for my daughter (K4TLI) and, of course, it’ll be fun to take it to the field from time to time.

Of course, the best way to get to know a radio, in my opinion, is to take it to the field. So that’s exactly what I did last week (January 13, 2021).

Blue Ridge Parkway K-3378

Against my better judgement, I decided to make a video of the activation. I mean, what could possibly go wrong operating a radio for the first time in the field? Right–?

I picked out an “easy” park for this activation: the Blue Ridge Parkway.

Although most of the parkway around Asheville, NC, is closed to vehicle traffic, the Folk Art Center is open year round and a very convenient spot for POTA.

Gear:

I paired the IC-703 Plus with my Chameleon MPAS 2.0 vertical antenna. I was curious how easily the IC-703’s internal ATU could match the MPAS 2.0: turns out, pretty darn well!

I started the activation on 40 meters phone (SSB).

Almost immediately, I logged a few contacts and that quickly built my confidence that even the default voice settings were working well on the IC-703 Plus.

I then moved to 40 meters CW and used the CW memory keyer to call CQ (I pre-programmed this before leaving the QTH that day).

Then I experienced a problem: when someone answered my call, my keyer didn’t work properly. For some reason, it was sending “dit dash” strings from both sides of the paddle. I’m not entirely sure what happened but assume there was either a radio glitch or a small short in my paddle cable. After fiddling with the IC-703 for a bit, I pulled out my Elecraft KX2 and finished the CW portion of my activation. (Always carry a spare radio, I say!)

Actually, I assumed since I was using the IC-703 for the first time, there could be hiccups as I did not do a full rig reset prior to putting it on the air–settings were essentially what they were when Don had the radio.

Here’s one of my real-time, real-life no edit videos of the entire activation, if you’re interested:

Back home, I connected my CW Morse paddles up to the IC-703 and it worked perfectly. Even though I checked the connections in the field, I must assume one of the plugs simply wasn’t fully-inserted. It hasn’t repeated this since.

Despite the CW snafu, I’m very pleased with the IC-703 Plus so far. I like the size for tabletop operating and it’s actually surprisingly lightweight.

If you own or have owned the IC-703, please comment!