Tag Archives: Tony (K2MO)

Tony tames X6100 audio with a simple ground loop noise isolator

Many thanks to Tony (K2MO) who writes:

Tom:

My X6100 arrived this week and I did notice some noise on the receive audio when wearing headphones. It shows up as a 1000 Hz tone with a few harmonics and it’s loud enough to make the audio a bit fatiguing to listen to. The good news is that the noise disappeared when I added a mini line isolator between the rig and headphones. It also removes the hiss!

Click here to view on Amazon (affiliate link).

I thought you’d be interested since you have the same rig so I recorded a short video that illustrates how well the isolator works.

You can see the 1000 Hz carrier and it’s harmonics appear in the audio spectrum when the line isolator is removed. You’ll also notice an increase in the audio noise floor.

X6100 Internal vs. External Speaker

I also uploaded a short video that shows how the X6100 audio sounds with the internal vs. external speaker.

Note that the ICOM speaker requires a mono-to-stereo adapter to work with the 6100. Plugging the speakers mono jack directly into the rig wont work.

The camera mic doesn’t do justice to how much better the rig sounds with the external speaker, but it should give you some indication.

Click to view on YouTube.

Thank you for sharing this, Tony!

I like how the isolator is such a simple solution and imagine it could help other radios with similar issues. Often these noises and harmonics come from display noise. Also, your video certainly shows the improvement using an external speaker on the X6100! Thank you for sharing!